MikroTik: WiFi Configuration – Simple Setup

The very common usage of a MikroTik WiFi router is to create a password protected wireless access point (WAP).

In this post I will show a very quick overview for beginners on setting up the WAP on the MikroTik router with the WiFi.

To start configuring the WiFi on the MikroTik router is is required to connect to it using a WinBox/WinFig (RouterOS graphical configuration tools) or over SSH, for once who prefer working in a command line.

Cool Tip: List MikroTik RouterOS firewall rules! Read more →

MikroTik WiFi Configuration

The important part is to make sure that the WAP is protected, so the first step is to create a security profile.

To create the security profile in the WinBox/WinFig interface, go to the “Wireless“, open the “Security Profiles” tab and click on the “➕” or “Add New“:

Think of a profile name, e.g. profile-0, choose the “dynamic keys” mode, select the “WPA2 PSK” as the authentication type, set the WiFi password in the “WPA2 Pre-Shared Key” field and click on “OK”.

From the command line interface all these can be done as follows:

> /interface wireless security-profiles \
             add name=profile-0 authentication-types=wpa2-psk mode=dynamic-keys \
             wpa2-pre-shared-key=passw0rd

The WiFi interface may be disabled at first time.

To enable it go to the “Wireless“, open the “WiFi Interfaces” (by default: wlan1), right-click on it and then click on “Enable”:

Then double-click on the wlan1 WiFi interface, select the previously created security profile and click on “OK”:

To enable the wlan1 WiFi interface and select the security profile from the command line:

> /interface wireless enable wlan1
> /interface wireless set wlan1 security-profile=profile-0

After this simple WiFi configuration you should able to find the SSID of the MikroTik WAP and connect to it using the password that has been set in the “WPA2 Pre-Shared Key” field during the security profile creation.

One Reply to “MikroTik: WiFi Configuration – Simple Setup”

  1. how to choose compression

Leave a Reply