YUM — Установить Конкретную Версию Пакета

По умолчанию, yum устанавливает самую последнюю версию пакета среди всех доступных версий из подключенных репозиториев.

Часто возникает необходимость установить не последнюю версию, а какую-то определенную или сделать даунгрейд уже установленного пакета до более ранней версии.

В этой заметке я показываю, как сделать так, чтобы yum отобразил список всех доступных версий указанного пакета и установил конкретную.

Дельный Совет: Не можете найти конкретную версию пакета? Установите EPEL-репозиторий и поищите необходимую версию там! Читать далее →

Показать Все Версии Пакета

Выполните следующую команду, чтобы показать все версии пакет, доступные в подключенных репозиториях:

$ yum list <имя_пакета> --showduplicates

Установить Конкретную Версию Пакета

Чтобы установить конкретную версию пакета, выполните:

$ sudo yum install <имя_пакета>-<версия>

Установить Старую Версию Пакета (Даунгрейд)

Если у вас уже установлена последняя версия пакета, но вам нужно сделать ее даунгрейд до конкретной более ранней версии, выполните:

$ sudo yum downgrade <имя_пакета>-<версия>

One Reply to “YUM — Установить Конкретную Версию Пакета”

  1. downgrade is useful, thanks

Добавить комментарий